Autoren, Google und eine WordPress-Multisite-Installation

Seit einigen Tagen werden ja mittlerweile auch in den deutschen Suchergebnissen von Google Name und Bild eines Artikel-Autors angezeigt. Das Ganze sieht dann in etwa folgendermaßen aus:

Rich Snippets Testing Tool
Ausschnitt aus dem Rich Snippets Testing Tool

Um so mehr ein Grund, den eigenen Blog dafür fit zu machen. Dachte ich mir zumindest. Welche Anleitung ich auch ausprobiert hatte, der Test mit dem Rich Snippets Testing Tool brachte immer die Meldung, dass keine Angaben zur Autorenschaft auf der getesteten Seite gefunden werden konnte (obwohl das Markup dafür immer richtig eingebaut war). Nach vielem hin und her fand ich nun heraus, dass es an der Permalinkstruktur des Blogs lag.

WordPress betreibe ich im Multisite-Modus, da ich noch verschiedene Nebenprojekte und Testumgebungen als extra WordPress-Blogs nutze. Alle Blogs werden als Unterordner der Domain angezeigt. Dabei bekommt der Hauptblog den Ordner /blog standardmäßig zugewiesen. Die Permalinkstruktur sah dann folgendermaßen aus: http://blog.lewumpy.de/blog/2012/03/titel-des-artikels. Änderte man die Permalinkstruktur in die Form http://blog.lewumpy.de/?p=123, dann zeigte das Rich Snippets Testing Tool die erfolgreiche Verifizierung der Autorenschaft an.

Um mich nun als Autor erfolgreich verifizieren zu können, war die (aus meiner Sicht) einzige Lösung, eine Kopie des Hauptblogs als Unterblog anzulegen, sodass er dann z.B. unter http://blog.lewumpy.de/blog-kopie/ erreichbar war. Mit Hilfe des Plugins WordPress MU Domain Mapping hab ich dann die eigentliche Adresse http://blog.lewumpy.de auf den Unterblog weitergeleitet. Ich gebe zu, dass diese Lösung nicht die eleganteste ist und noch dazu je nach Blogumfang relativ aufwendig ist, allerdings hatte ich im Netz auch keinen anderen Lösungsweg gefunden. Nach der Umstellung auf einen Unterblog, wurden nun die Artikel auch mit der Permalinkstruktur Jahr/Monat/Titel erfolgreich verifiziert.

[yellow_box]P.S.: Es besteht die Möglichkeit, als Netzwerkadmin unter Blogs >> Alle Blogs >> Bearbeiten [beim Hauptblog] >> Einstellungen >> Permalink Structure den Teil /blog zu löschen. Davon sollte man allerdings abraten, da man damit im schlimmsten Fall die ganze Seite zerstören kann. Bei mir hatte es dazu geführt, dass die einzelnen Artikel zwar ohne das /blog erreichbar waren. Allerdings enthielten die Links im Loop immer noch den /blog-Teil und führten dann zu einem 404-Fehler.[/yellow_box]

Programm-Versionen, auf die sich dieser Artikel bezieht:

WordPress: 3.3.1

Autoren, Google und eine WordPress-Multisite-Installation

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.